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1 Introduction

1.1 About this manual
This manual describes how to use the Wanco® Message Graphics software program to 
create custom messages for Wanco full-matrix variable message signs. For ease of use, a 
basic understanding of how to use a computer is required.

This manual does not include any information about using the message sign. See the 
message sign owner’s manual.

1.2 Where to obtain service
Before calling for service, please have the software version number ready. Locate the 
version number by choosing Help > About.

Contact our service department using the following information:

Wanco Inc.
5870 Tennyson Street
Arvada, Colorado 80003

303-427-5700
fax 303-427-5725

www.wanco.com
info@wanco.com
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2 Before You Begin

2.1 System requirements
The Wanco Message Graphics program may be installed on any computer running 
Microsoft® Windows® XP, Vista, 7, 8 or later.

The message sign for which you will be designing messages must be a Wanco matrix 
message sign.

2.2 Installation
The Wanco Message Graphics program is available for download at www.wanco.com. 
Contact the Wanco service department for access (see Section 1.2, “Where to obtain 
service,” page 1).

After downloading the program and saving it to your computer, install it by opening 
the file and following the on-screen instructions.

2.3 Running the program
To run the program, click the Wanco icon on your Windows Desktop, or choose Wanco 
Message Graphics from your Start menu.
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3 Using the Program

3.1 Overview
Using the program to create custom messages involves three general steps:

1. Create a new message or edit an existing message

See Section 3.2 for an overview of the program windows. More details are presented in 
Sections 3.4 and 3.5.

2. Save the message

See Section 3.3 for an explanation of file types.

3. Transfer messages to the message sign computer

See Section 4 to learn how to transfer messages to the sign.

3.2 Program windows
The Wanco Message Graphics program has three main windows:

■ The Message window (Figure 3-1) displays the message you are creating, and lets you 
position the objects you create with drawing tools.

■ The Tools window (Figure 3-2) lets you choose drawing tools for creating your custom 
messages.

■ The Background Editor window lets you import an external image file (Figure 3-3) to 
use as a background for a message, and edit an imported background image 
(Figure 3-4).

If a window is too small to show everything in the window, you may resize it by clicking 
and dragging the lower-right corner of the window. (The elements in the window will 
not change size.)
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Figure 3-1.  Message window

Figure 3-2.  Tools window
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Figure 3-3.  Background Editor window in image-import mode

Figure 3-4.  Background Editor window in bitmap-edit mode
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3.3 Getting started
3.3.1 Overview

When you create a new message, you begin by selecting the message sign model, then 
you use tools and options to create your message. When you are done, you must export 
your message as a file that can later be transferred to the message sign computer.

The program saves messages in a proprietary file format that can later be opened and 
edited, if desired. See below for descriptions of file types and how to use them.

You can open more than one Message window at a time, creating multiple messages 
for one sign model or various models.

3.3.2 Creating a new file
Before you can create a new file, you must first choose the message sign model for 
which you will be designing your message. Each model has a specific number of pixels; 
a message you create for one model may not work on another model.

To choose the message sign model, choose File > New, and then select the desired 
model.

After you select a message sign model, the model number and pixel dimensions (width 
by height) are displayed in the Message window (see Figure 3-1).

3.3.3 Saving message files
After creating a message, you should save it as a file that can later be opened and 
edited in the Message Graphics program.

■ To save a file, press the Save button  in the Message window.

■ To save an existing file with a new file name, choose File > Save As.

3.3.4 Saving templates
You can save shape and text objects as templates that can be placed into a message. 
Template objects can be modified after you place them. You cannot save backgrounds 
as templates.

■ To create a template, use the Selection tool  in the Message window to select the 
objects you want to save, then click the Create Template button .

■ To select more than one object, press and hold the Ctrl key while clicking with the 
Selection tool. To select all objects, choose Edit > Select All in the Message window.

3.3.5 Opening files
When you open a Message Graphics (.wgr) file, all the components of the message—
the background, all objects, and all pages—are available for editing.

■ To open a file, choose File > Open or press Ctrl-O.

■ To open a recently used file, choose File > Recent Files in the Tools window.
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3.3.6 Importing files

Message files

Message sign messages are saved as NTCIP-compatible MULTI* (.multi) files that the 
Message Graphics program can import.

When you import a MULTI file, the message is imported as a bitmap image, which can 
be edited using the Background Editor window. To add new objects to the message, 
use the drawing tools in the Tools window.

■ To import a MULTI file, use the Message window and choose File > Import from .multi. 
When importing multi-page messages, all pages are imported.

■ To edit an imported message, click the Add/Edit Background  button in the Tools 
window.

Background images

You can import an image file into your message to use as a background. To import a 
background image, see Section 3.5.5, page 15.

3.3.7 Exporting files
When you are ready to transfer your message to a message sign (see Section 4, 
page 19), you must export your message — either as an NTCIP-compatible MULTI file on 
your computer, or directly to the message sign if your computer is connected to it.

Export to MULTI file

To export your message to a MULTI file:

1. Use the Message window and choose File > Export > Export to File. 

2. Check or uncheck the Export as Cxxx.multi check box.

■ When checked, the program automatically saves the file with a file name that the 
message sign will recognize as a custom-message number.

■ You can overwrite the automatic file name with your own, for saving it on your 
computer; but it will then be necessary to configure the message number when 
you transfer the file to the sign.

3. If the check box was checked, choose or enter a message number from 1 to 150. Your 
message will be saved with a file name that includes the message number you choose 
(e.g., C001.multi, C035.multi).

4. Choose whether you would also like to save your message as a JPEG image file.

You might want to save a JPEG image for reference, so you can view it in an image 
viewer without opening the Remote Graphics program. This can be particularly useful 
when you have a collection of messages.

5. Click OK.

*MULTI (Mark-Up Language for Transportation Information) is a language (not an object) used to convey a 
Message (Text and Message Attributes) between two entities. (NTCIP 1203 v03.04, §6.1. May 2011.)
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Export to message sign

When exporting your message directly to a Wanco message sign, your computer must 
be connected to the sign—wirelessly, using an Internet connection and a cellular 
modem at the sign; or directly, using an Ethernet cable connected to the message sign 
computer. 

To export your message directly to a message sign, see Section 4.2.1, page 19.

3.4 Message window
3.4.1 Sign model

Before you create or edit a message, you should ensure that the sign model is correct.

When creating a new message, you must first choose a message sign model, because 
each model’s display has a specific number of pixels. A message you create for one 
model may not work on another model.

The Sign Model area in the Message window lists the message sign model number and 
pixel size (width by height) for the message you are creating or editing. The sign model 
is saved with the Message Graphics file so that, if you open the file for editing, the 
program can show the correct model.

3.4.2 Message area
Create or edit your message in the message area, using tools in the Tools window. 
When using a tool, you select it, then click in the message area to use it.

If the message has multiple pages (see Section 3.4.4), click in the message area for the 
page you want to change. The selected page is indicated with a black border.

The Cursor Coordinates indicator shows you where your cursor is located in the 
selected page, so that you can accurately position drawing and text objects.

3.4.3 Magnification
The magnification area allows you to zoom the message area in or out. 

Each pixel in the message area represents a pixel on the message sign display. Because 
a pixel on your computer screen is very small (approximately 1/72 inch), it is helpful to 
be able to make the message area larger, so you can see what you are doing.

3.4.4 Message pages
A message can appear all at once or on multiple “pages,” alternating between two 
pages (for example, 1,2,1,2. . . ) or sequencing between more than two pages (for 
example, 1,2,3,1,2,3. . . ).

You can select any page by clicking on it. The Selected Page indicator in the Message 
window shows the number of the currently selected page. Additionally, a black border 
appears around the selected page in the message preview area.
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Adding and deleting pages

By default, a new message has one page. You can add up to 9, for a total of 10. New 
pages are added after the last page. When you open the file for a multi-page message, 
all pages will be shown.

■ To add pages to the end of your message, click the Add Page  button.

■ To delete a page, click on it in the message area, then click the Delete Page  button.

Copying objects from one page to another

You can copy and paste objects from one page to another. When pasted on a new 
page, a copied object is positioned in the same location.

To copy and paste objects:

1. Use the Selection tool  in the Message window to select the objects you want to copy. 

■ To select more than one object, press and hold the Ctrl key while clicking with the 
Selection tool.

■ To select all objects, choose Edit > Select All in the Message window.

2. Copy the selected objects by choosing Edit > Copy or pressing Ctrl-C.

3. Click on the page you want to paste the objects into, then choose Edit > Paste or press 
Ctrl-V.

4. Repeat Step 3 for each page you want to paste the objects into.

3.4.5 Color intensity
When creating or editing a message for a color message sign, the Color Intensity area is 
visible in the Message window. Use the Color Intensity drop-down menus choose the 
intensity for each color in the message.

The intensity is significant, because some color combinations have less contrast than 
desired when viewed on the message sign display. For example, if blue and white pixels 
appear next to each other on the sign, and they are both set to full (High) intensity, they 
may be indistinguishable; therefore, you might choose to set the blue intensity to Low, 
which will make the white stand out by comparison.

Colors set to low- and medium-intensity appear muted in the message area.



12 User’s Manual

Wanco® Message Graphics

3.4.6 Edit menu
The Edit menu has options to make creating and editing a message easier, including 
some that are also in the button bar:

IMPORTANT!

Do not confuse the color intensity setting in the Message Graphics program with 
display brightness on the message sign.

Wanco message signs are designed to get brighter and dimmer depending on ambient 
light. The less ambient light, the dimmer the sign, which conserves energy and 
improves performance.

Because the color intensity you choose for each color is relative to the other colors, and 
the brightness of the message on the sign is relative to ambient light, it is possible to 
choose High intensity and have it displayed on the sign at less than 100% brightness. 
This is intentional, not a flaw.

Because some color combinations have low contrast, it is important to choose color 
intensity without regard for display brightness. If designed with proper intensity 
settings, your message will be displayed equally well at low and high brightness.

Select All Selects all objects on the active message page

Unselect All Deselects all objects on the active message page

Delete Permanently removes the selected objects

Delete All Permanently removes all objects on the active message page

Move to Front Moves the selected objects in front of all other objects on the active 
message page

Move to Back Moves the selected objects behind all other objects on the active 
message page

Group Combines the selected objects into a single grouped object so they 
can be treated as a single unit

Ungroup Separates the selected group into individual objects so that they can 
be handled one at a time

Copy Copies the selected objects

Cut Copies and removes the selected objects

Paste Inserts the copied objects in the active message page

Add Page Adds a new blank page to the end of the message

Delete Page Permanently removes the active message page
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3.4.7 Button bar
The button bar provides easy access to commonly used options, including some that 
are also in the Edit menu:

3.5 Tools window
3.5.1 Drawing and shape tools

Select drawing tools in the Tools window and use them to place objects in your 
message by clicking in the message area in the Message window.

Most tools can be configured using the shape tools and color selector in the Tools 
window. You can configure a tool before using it to create an object; but you can also 
reconfigure an object after creating it, by selecting it in the message area and then 
changing the options with the shape or text tools.

Tips for using drawing tools

■ To keep a shape’s proportions before you draw, select the tool, then hold down the 
Shift key before clicking and dragging with the tool in the message area of the 
Message window. Release the Shift key after drawing the object. Thus a rectangle 
becomes a square, and ellipse becomes a circle, and so on.

Save Saves the message as a fully editable Message Graphics (.wgr) 
file

Create 
Template

Saves the selected objects as a fully editable template (.wgt) 
file

Select Activates the selection tool for selecting objects in the 
message area

Move to Front Moves the selected objects in front of all other objects on the 
active message page

Move to Back Moves the selected objects behind all other objects on the 
active message page

Group Combines the selected objects into a single grouped object so 
they can be treated as a single unit

Ungroup Separates the selected group into individual objects so that 
they can be handled one at a time

Delete Permanently removes the selected objects

Add Page Adds a new blank page to the end of the message

Delete Page Permanently removes the active message page

Undo Lets you undo previous operations

Redo Lets you redo operations you have undone
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■ To keep a shape’s proportions when resizing it, select the object, then hold down the 
Shift key before clicking and dragging one of the object’s corner anchor points. 
Release the Shift key after resizing the object.

■ To draw a horizontal or vertical line or arrow, or a 45-degree arrow, select the tool, then 
hold down the shift key before clicking and dragging with the tool in the message area 
of the Message window.

■ When drawing a shape, you can choose a pen width with the shape tools. Pen width is 
the number of pixels the shape will have as a border on the message sign. You can also 
choose the border color.

■ When drawing a triangle, you can choose whether the triangle points down or up.

■ When drawing an arrow, you can choose a size for the arrowhead.

Drawing tool buttons

Rectangle Lets you draw a rectangle or square

Ellipse Lets you draw an ellipse or circle

Line Lets you draw a straight line

Polygon Lets you draw a free-form polygon shape

Text Lets you insert text into your message

To use the text tool, first select the tool, then click in the 
message area of the Message window, then return to the 
Tools window and type your text in the Enter Text box.

When using the text tool, you can use the text tools to 
configure line spacing, justification, and the font. You can also 
choose whether your text should be all upper-case letters.

Octagon Lets you draw an octagon

Diamond Lets you draw a diamond shape

Triangle Lets you draw a triangle

Arrow Lets you draw an arrow shape

Template object Opens the Template Selection window, which lets you insert 
previously saved objects into your message

The Template Selection window displays icons for each 
template you have saved (see “Saving templates,” page 8). You 
can also choose the file folder where these templates are 
saved.

Click an icon to insert the template into your message.

Select Activates the selection tool for selecting objects in the 
message area of the Message window
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3.5.2 Color selector
The color selector lets you choose the fill color for an shape or text object. The border 
color is determined based on the choices you make with the shape tools.

When creating or editing a message for a color message sign, all the colors are 
available; otherwise, only amber and black are available.

To change the color of an object you have already created, select it in the message area 
and then click a color in the color selector.

3.5.3 Test tools
The test tool is a Play  button that lets you preview an animated multi-page 
message. Click in the Message window before clicking the Play button.

After you click the Play button, the Playback window opens. You can click the Play 
button in that window to animate your message, or click Forward  or Reverse  to 
browse through your message pages one at a time. An indicator at the top of the 
window tells you which page is being displayed. Click Stop  to end the animation.

3.5.4 Page times
You can configure page times for multi-page messages. Using the settings in the Page 
Times area, you can set both the page-on and page-off times.

When setting page times, note the page number indicated in the Page Times area. Each 
page of a multi-page message can be configured individually.

Ensure that your settings are appropriate for your message and the intended 
application of the message sign.

3.5.5 Background image
You can create a background for your message using an image file, such as a 
photograph, logo, or other graphic image. Simple images work best, because the 
message sign can only display a limited number of colors. 

You can also edit an existing background, copy a background from one message page 
to another, and convert shape and text objects to a background.

A background is a bitmap image* that can only be modified using the editing tools in 
the Background Editor window.

*A bitmap image consists of an array of dots, each filled with a solid color. In the Message Graphics program, 
each dot represents a pixel on the message sign.
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Add a background image

To add a background image to your message:

1. Click the Add/Edit Background  button in the Tools window to open the 
Background Editor window. Use the Background Editor for the rest of this procedure.

2. Insert an image into the Original Image area using one of the following methods:

■ Locate the image file on your computer, then click and drag it into the Original 
Image area.

■ Open the image file in any appropriate program on your computer, and copy it to 
the clipboard. Then, click anywhere in the Background Editor and paste the image 
by pressing Ctrl-V.

3. Size and crop the image:

a. Use the Scale slider to resize the image in the Original Image area, so that the 
desired portion of the image fits the crop box (Figure 3-5).

b. Click and drag the crop box until the desired portion of the image appears in the 
Cropped Image area.

4. Make adjustments:

a. To achieve the background you desire, use the Scale and Contrast sliders, and 
move the crop box, until the Mapped To Sign preview shows what you want it to 
show. Use the Magnification options to enlarge or reduce the preview for a better 
look at your image.

b. If desired, click the Edit Bitmap button to make changes to the image using the 
editing tools (see “Background Editor tools,” page 17).

5. When you are done creating your background, click the Accept button. To exit the 
Background Editor without saving your background, click the Cancel button.

Figure 3-5.  Image crop area

Crop box

The size and proportion of the 
image crop area conforms to the 
message sign model for which 
you are creating your message. 
They cannot be changed.
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Edit a background image

To edit a background image:

1. Click the Add/Edit Background  button in the Tools window to open the 
Background Editor window.

2. To replace your background with a new image, use the “Add a background image” 
procedure, above.

3. To edit your background, click the Edit Bitmap button and use the editing tools (see 
below).

Background Editor tools

Copy a background image

You can copy a background from one page to others in a multi-page message. To copy 
a background:

1. In the Message window, select the message page with the background you want to 
copy.

2. In the Tools window, click the Copy Background  button.

3. In the Message window, click the page or pages you want to copy the background into.

4. Exit the copy-and-paste mode by clicking the Copy Background button, or by pressing 
the Esc key, or by selecting another tool.

Draw Draws a single pixel of the selected color

Fill Fills the area you click with the selected color

Select Area Lets you choose an area to copy

Click and drag the area you want to copy, then press Ctrl-C to 
copy it.

After copying, press Ctrl-V to paste. The copied portion of the 
background will be pasted wherever you click. 

Click repeatedly to create a pattern. If you make a mistake, 
press Ctrl-Z to undo, then click again to continue pasting.

Exit the paste mode by pressing Esc on your keyboard.

Clear Erases the entire background

Negative Converts all colors to their opposites

Discard Edits Reverts to the background you started with

If you revert by accident, you can recover your last change if 
you click the Edit Bitmap button before you click anything 
else, and then press Ctrl-Z.
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Convert foreground objects to background image

After creating part of a message, you may want to convert it to a background. 

The objects you create are fully editable —that is, they can be resized and moved, their 
fill and border colors can be changed, etc. Note, however, that a background is a 
bitmap image, and your ability to edit the background is limited.

To convert a message to a background:

1. In the Message window, select the message page you want to convert.

2. In the Tools window, click the Convert to Background  button.

IMPORTANT!

After you convert a message to a background, you cannot undo the conversion.
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4 Transferring messages to the sign

4.1 Overview
Before you can transfer your message to a message sign, you must either connect your 
computer to the sign or export your message as an NTCIP-compatible MULTI file.

■ If your computer is connected to the message sign—wirelessly, using an Internet 
connection and a cellular modem at the sign; or directly, using an Ethernet cable 
connected to the message sign computer:

❑ You can export your message directly from the Message Graphics program to the 
sign (see Section 4.2.1).

❑ You can use the Wanco Remote Control program to transfer your message to the 
sign (see Section 4.2.2).

■ If your computer is not connected to the message sign, you can transfer the file to the 
message sign computer using a USB flash drive (see Section 4.2.3).

4.2 File transfer
4.2.1 Export to sign

The Message Graphics program can transfer a message directly to a Wanco message 
sign if your computer is connected to the sign (see Section 4.1).

To export your message directly to a message sign:

1. Ensure your computer is connected to the message sign computer—wirelessly, 
through a cellular modem; or directly, with an Ethernet cable.

2. Use the Message window and choose File > Export > Export via IP. 

3. Enter the message sign IP address.

4. Change the port only if necessary.

5. Enter the numerical portion of the custom-message number (i.e., do not enter the “C”).

6. If you want the message to be activated on the sign as soon as it is exported, ensure the 
Activate Message check box is checked.

7. Click Send.

IMPORTANT!

When you upload messages to the sign, messages already on the sign that have the 
same message numbers as your new messages will be replaced and cannot be 
recovered.
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4.2.2 Transfer with Wanco Remote Control
The Wanco Remote Control program lets you interact with a Wanco message sign using 
a personal computer, an Internet connection, and a cellular modem installed at the 
sign.

One function of the program is to upload messages from your computer to the sign’s 
control system. Before you can upload your message to the sign, you must export it as a 
MULTI file (see Section 3.3.7, page 9).

To transfer a message to the sign:

1. Run the Remote Control program and connect to the message sign.

2. Choose a message number using the selector (see Figure 4-1). The number you choose 
will be the number of the custom message for your imported message (C001, C002, 
C003, . . . through C150).

3. Click the Preview Msg# button.

4. Click the Import Msg button.

5. Locate the file you want to import from your computer.

6. Click OK. The message will be imported as the message number you chose in Step 2. 

After importing your message, you can choose to activate the message on the sign, 
import another message, or perform other tasks.

Figure 4-1.  Wanco Remote Control program

IMPORTANT!

When you upload messages to the sign, messages already on the sign that have the 
same message numbers as your new messages will be replaced and cannot be 
recovered.

Preview Msg# button

Import Msg button

Message number selector
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4.2.3 Transfer from USB flash drive
You can choose to transfer one or many messages to a message sign using a USB flash 
drive. When transferring files using this method, the file names must be in the format 
Cxxx.multi, where “xxx” is the custom-message number (C001.multi, C035.multi, etc.). 
Before you can upload messages to the sign, you must export them as MULTI files (see 
Section 3.3.7, page 9).

To transfer messages to the sign, follow the procedure described below.

1. At your computer:

a. Download the MessageTransfer.zip file from www.wanco.com. Contact the Wanco 
service department for access to the file (see Section 1.2, “Where to obtain service,” 
page 1).

b. Unzip the files contained in MessageTransfer.zip to the root directory on your flash 
drive. You should see two files on the flash drive: autorun.sh and 
installCMessages.sh (see Figure 4-2).

c. Copy one or more MULTI files from your computer and paste them into the root 
directory on your flash drive (see Figure 4-3). Copy and paste all of the MULTI files 
you want to transfer to the message sign.

d. Eject the flash drive and remove it from your PC.

Figure 4-2.  Example: Flash drive root directory with message-transfer files

IMPORTANT!

When you upload messages to the sign, messages already on the sign that have the 
same message numbers as your new messages will be replaced and cannot be 
recovered.

Two message-transfer 
files
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Figure 4-3.  Example: Flash drive root directory with all files

2. At the message sign:

a. Configure the sign to show a message. Choose any message. This is so you can see 
when the sign restarts later in the procedure.

b. Insert the flash drive into the USB port on the sign’s computer box. This port could 
be located on front of the black box located inside the sign’s battery box or (for 
truck-mounted signs) behind the seat in a vehicle cab, or on the right side of the 
control panel inside the sign’s control box.

c. When the flash drive is inserted into the USB port, the file transfer will begin. The 
sign’s computer will load the new messages and then restart the sign. This process 
should take less than two minutes.

d. After the sign restarts and the message you chose appears on the display, then 
remove the flash drive from the USB port.

After the sign restarts, your new messages will be available for immediate use.

Message-transfer files

MULTI files

Your files may have 
different file names
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